it-swarm-fr.com

JCE n'apparaissant pas pour les groupes d'utilisateurs frontaux personnalisés

Pour une raison quelconque, je ne peux pas faire en sorte que le éditeur JCE apparaisse pour mes groupes d'utilisateurs personnalisés dans front-end .

J'ai essayé tellement de combinaisons et je ne peux toujours pas le faire fonctionner.

Pour le moment, je me suis retrouvé avec uniquement le profil JCE par défaut , attribué à tous les groupes, à l'exception du groupe invité, et j'ai également donné des autorisations étendues à ces derniers. groupes.

Néanmoins, l'éditeur (en mode frontal) ne s'affiche que pour les groupes disposant d'un accès principal et non pour ceux disposant uniquement d'un accès frontal.

Je l'ai vérifié également avec le gestionnaire d'ACL mais je n'ai rien remarqué apparemment d'anormal ... Une autre chose à noter est qu'il n'y a pas de conflit JS qui pourrait causer des problèmes.

Est-il possible qu'il me manque quelque chose d'évident, lié à ACL ou à un paramètre quelque part qui gère l'accès des éditeurs au front-end?

3
FFrewin

Les gars, après avoir bricolé avec la liste de contrôle d'accès dans tous les autres endroits et après avoir recherché toutes sortes d'autres problèmes possibles pendant quelques heures, j'ai finalement réussi à résoudre ce problème.

Le problème était dû au paramètre paramètres de la liste de contrôle d'accès situé sur le plug-in JCE Editor, appelé lors du chargement de l'éditeur. Il avait le niveau d'accès à l'administrateur, de sorte que tous les utilisateurs du front-end étaient incapables d'obtenir l'accès et de charger l'éditeur.

J'ai défini son accès sur Public et maintenant je charge l'éditeur sur Front-end pour tous mes groupes d'utilisateurs.

3
FFrewin