it-swarm-fr.com

Problème de mise à jour automatique de WordPress 3.0.1

Mon WordPress est maintenant à la version 2.7. Je veux le mettre à jour en 3.0.1 en utilisant la fonction de mise à jour automatique. J'utilise le type de connexion FTPS.

La mise à niveau devrait être simple, cependant, je rencontre toujours cette erreur:

Échec de l’installation du téléchargement de la mise à jour depuis http://wordpress.org/wordpress-3.0.1.Zip

Déballer la mise à jour…

Vérification des fichiers décompressés…

Installer la dernière version…

Impossible de copier le fichier .: /wp-admin/css/theme-editor.dev.css

L'installation a échoué

J'ai vérifié l'autorisation pour le dossier /wp-admin/css et sa valeur est 777.

Quel est le problème? J'ai cherché sur Internet, mais il semble que beaucoup de personnesaient le même problème .

Des idées?

2
Graviton

La mise à jour automatique ne fonctionne pas toujours, cela fonctionne presque toujours. Je voudrais simplement mettre à niveau manuellement et ne vous inquiétez pas pour cela. Les quelques fois où j'ai eu un échec de mise à jour automatique, cela réussit la prochaine fois qu'une nouvelle version est disponible (après que je sois mis à jour manuellement pendant la rupture).

2
curtismchale

Il existe un correctif (http://core.trac.wordpress.org/ticket/10913) pour WordPress qui devrait aller dans la version 3.2 et aider à corriger cette erreur de mise à niveau pour la plupart des personnes qui l'utilisent. Cela ne semble se produire qu'avec des serveurs exécutant Pure-FTPd. En attendant, il existe un plugin qui devrait aider à corriger les mises à jour pour la plupart des gens: http://wordpress.org/extend/plugins/ftp-upgrade-fix/

2
user3757

Vérifiez le propriétaire du fichier/s, vous pouvez l'avoir défini 777, mais si le service ftp n'est pas dans le groupe de propriétaires ou le propriétaire, cela peut poser problème.

Vous devez établir une connexion telnet sur le serveur Web pour vérifier/résoudre ce problème. Ls -l pour afficher les paramètres définis, procédez comme suit.

0
Pbearne

J'ai tout essayé pour la mise à niveau automatique mentionnée à wordpress.org/support/topic/upgrade-gone-worng-pls-help, mais en vain.

Au lieu de cela, j'ai effectué une mise à niveau manuelle plus ou moins en suivant les instructions fournies à codex.wordpress.org/Upgrading_WordPress. Au lieu d’utiliser FTP, j’ai utilisé mes fournisseurs d’hébergement, CPanel - j’ai ensuite blogué les mesures que j’avais prises pour que d’autres en tirent profit - voir http://misterjaytee.com/2010/09/11/errors -updating-wordpress .

J'espère que la prochaine mise à niveau automatique fonctionnera correctement, mais si ce n'est pas le cas, j'ai maintenant la confiance nécessaire pour effectuer la mise à niveau manuellement.

0
misterjaytee
0
Nabeel

Vérifiez les autorisations sur le fichier référencé. Dans ce cas: /wp-admin/css/theme-editor.dev.css.

0
artlung