it-swarm-fr.com

Impossible d'installer la version essentielle sur CentOS

Lorsque j'exécute la commande:

Sudo apt-get install build-essential

Je reçois le message d'erreur suivant:

Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package build-essential
79
Waley Chen

Je crois que cela devrait encore fonctionner.

Sudo yum groupinstall 'Development Tools'
129
Scott Likens
yum install gcc gcc-c++ make 

Cela fonctionne équivalent à build-essential dans CentOS.

48
Ketan Patel

Le métapaquet build-essential est fourni sur Debian pour collecter tous les outils de construction essentiels couramment requis dans la chaîne de construction Debian, y compris ceux dont vous avez besoin pour créer .deb paquets. Centos utilise un gestionnaire de packages différent et ne fournit pas directement quelque chose comme ça; vous devrez installer manuellement les composants individuels de la chaîne d'outils (gcc, make, bibliothèques de développement communes, documentation, etc., ainsi que bien sûr les outils pour créer des packages RPM si vous le souhaitez pour faire ça).

Si vous supprimez le .deb ou trucs RPM, gcc, gcc-c++, glibc-devel et make devraient actuellement obtenir les packages Centos correspondants.

5
tripleee

J'ai combiné la solution acceptée de Scott Likens avec le commentaire de user12345, et j'ai d'abord regardé ce qui était dans le groupe "Outils de développement" avant l'installation.

Comme l'a souligné user12345, vous pouvez le faire avec:

$ yum group info "Development Tools"

Je voulais installer des packages comme autoconf et automake et binutils, mais je n'avais pas besoin de doxygen ou ant ou Mercurial.

Vous trouverez ci-dessous la liste que j'ai utilisée, ainsi que leurs dépendances, mais bien sûr, votre kilométrage peut varier, en fonction de VOS besoins.

$ yum install \
    autoconf automake binutils \
    bison flex gcc gcc-c++ gettext \
    libtool make patch pkgconfig \
    redhat-rpm-config rpm-build rpm-sign \
    ctags elfutils indent patchutils 
2
m0j0
Sudo yum install -y libxml2 libxml2-devel libxslt libxslt-devel
0
Waley Chen