it-swarm-fr.com

Erreur lors de la mise à niveau de 2.9.2 à 3.0.1

J'ai mon wordpress installer sous svn. J'étais sur la version 2.9.2. Ce sont les étapes que j'ai prises:

  • enregistré une copie de mon répertoire wordpress actuel
  • cd dans mon répertoire wordpress de premier niveau
  • svn up (juste pour m'assurer que j'ai le dernier en date de 2.9)
  • svn sw http://core.svn.wordpress.org/tags/3.0.1/ . (mise à niveau)
  • lancer wp-admin/upgrade.php
  • vous avez cette erreur "Erreur fatale: appel de la fonction non définie is_multisite () dans (mon répertoire d'installation) /wordpress/wp-includes/wp-db.php à la ligne 505"

J'ai regardé autour de moi et certaines personnes pensent que c'est un problème de mémoire avec PHP. J'ai donc essayé le plugin Memory Bump et cela n'a pas fonctionné.

Des idées?

Mise à jour: Trouvé ce message . J'ai téléchargé la dernière version 3.0 et remplacé mon fichier wp-settings.php par celui du téléchargement.

Obtenez des erreurs différentes maintenant. "Erreur fatale: impossible de redéclarer wp_load_image () (précédemment déclaré dans /myinstalldir/wordpress/wp-includes/media.php:241) dans/ moninstalldir /wordpress/wp-admin/includes/image.php on line 168 "

Quand j'exécute et svn status, je vois beaucoup de drapeaux 'S' (commutés). Dois-je me préoccuper de cela? wp-settings.php a cet indicateur.

Mise à jour: Voici la sortie du svn sw ci-dessus à partir du répertoire racine de Wordpress.

Mise à jour: Sortie de svn stici . (Migration des longues listes vers Pastebin)

Mise à jour: Sortie de svn info

Path: .
URL: http://core.svn.wordpress.org/tags/3.0.1
Repository Root: http://core.svn.wordpress.org
Repository UUID: 1a063a9b-81f0-0310-95a4-ce76da25c4cd
Revision: 15559
Node Kind: directory
Schedule: normal
Last Changed Author: ryan
Last Changed Rev: 13165
Last Changed Date: 2010-02-15 09:38:59 -0800 (Mon, 15 Feb 2010)
1
milesmeow

J'ai également utilisé SVN avant de mettre à jour mon installation wordpress. La copie de travail sera rapidement mélangée avec toutes les mises à jour manuelles ou les fichiers créés par les plugins.

Je recommanderais toujours d'utiliser la fonctionnalité de mise à jour de wordpress si vous voulez seulement passer d'une version étiquetée à une autre.

Bien que j'utilise aussi SVN pour une copie locale de wordpress afin de pouvoir tester rapidement mes plugins dans une ancienne version très rapide. J'utilise Eclipse pour passer d'une balise à une autre et jusqu'à maintenant, tout se passait bien. Mais vous ne saurez jamais.

UPDATE: Je viens d'essayer de passer un checkout propre de 2.9.2 à 3.0.1 qui semble fonctionner, mais je ne peux que voir le backend et non le frontend du blog unique par défaut.

UPDATE: Ce que même le mode débogage ne me dit pas: le thème par défaut pre WP 3.0 n'est plus disponible Je dois juste passer au nouveau thème "2010". Maintenant tout fonctionne.

La commutation fonctionne donc, mais comme je l’ai déjà dit, votre copie de travail est généralement gâchée par de nombreux fichiers qui pourraient poser problème pour la mise à jour de votre copie WP avec le commutateur SVN.

2
2ndkauboy

On dirait que vous avez exécuté svn sw dans un sous-répertoire plutôt que dans le répertoire WordPress de niveau supérieur. Nous pourrons peut-être vous aider à récupérer, si vous ne pouvez pas simplement récupérer une copie vierge et passer au-dessus de vos plugins et de vos thèmes. La sortie complète de svn st serait utile, ainsi que svn info pour tout répertoire ayant pu être commuté indépendamment de son parent.

0
Annika Backstrom