it-swarm-fr.com

Forcer Internet Explorer à utiliser une installation spécifique Java Runtime Environment??

Lors de l'affichage de la page Web de quelqu'un d'autre contenant une applet, comment puis-je forcer Internet Explorer 6.0 à utiliser un JRE particulier lorsque plusieurs d'entre eux sont installés?

46
Mark MacIver

Commencez par désactiver la version de Java actuellement installée. Pour ce faire, accédez à Panneau de configuration> Java> Avancé> Par défaut Java pour les navigateurs) et décochez Microsoft Internet Explorateur.

Ensuite, activez la version de Java que vous souhaitez utiliser à la place. Pour ce faire, accédez à (par exemple) C:\Program Files\Java \jre1.5.0_15\ bin (où jre1.5.0_15 est la version de Java que vous souhaitez utiliser) et exécutez javacpl.exe Allez dans Avancé> Par défaut Java pour les navigateurs et cochez Microsoft Internet Explorer.

Pour récupérer votre ancienne version de Java), vous devez inverser ces étapes.

Notez que dans les anciennes versions de Java, Par défaut Java pour les navigateurs est appelé <APPLET> Prise en charge des balises) (mais l'effet est le même) .

La bonne chose à propos de cette méthode est qu’elle n’affecte pas les autres navigateurs ni le JRE système par défaut.

72
Daniel Cassidy

J'ai le même problème aujourd'hui et je suis d'accord avec Jack Leow. Sur Windows XP, je devais utiliser le Panneau de configuration> Java, puis:

  1. Onglet Java
  2. Cliquez sur le bouton "Voir"
  3. Activer uniquement le JRE que je veux (c'est-à-dire JRE 1.5.x et laisser 1.6.x désactivé)
  4. Redémarrer IE
  5. Charger la page de l'applet dans IE
  6. Et voila, ça charge la bonne version de JRE!
21
Kayhadrin

Pour la solution côté serveur (à propos de laquelle votre question était à l'origine ambiguë), cette page sur Sun répertorie un moyen de spécifier un environnement JRE. Plus précisément,

<OBJECT 
  classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"
  width="200" height="200">
  <PARAM name="code" value="Applet1.class">
</OBJECT>

L'attribut classid identifie la version de Java Plug-in à utiliser.

Voici une forme alternative de l'attribut classid:

classid="clsid:CAFEEFAC-xxxx-yyyy-zzzz-ABCDEFFEDCBA"

Sous cette forme, "xxxx", "yyyy" et "zzzz" sont des nombres à quatre chiffres qui identifient la version spécifique de Java Plug-in à utiliser.

Par exemple, pour utiliser Java Plug-in version 1.5.0, vous spécifiez:

classid="clsid:CAFEEFAC-0015-0000-0000-ABCDEFFEDCBA"
4
BrezzaP

Je voudrais d'abord essayer toutes les réponses ici. Mais je voulais juste ajouter ce que je fais, juste au cas où cela ne fonctionnerait pas pour vous.

J'ai essayé de résoudre le même problème que vous aviez auparavant et, au final, j'ai décidé de ne faire installer qu'un seul JRE sur mon système à la fois. J'ai environ 10 JDK différents (de 1,3 à 1,6, et de différents fournisseurs - Sun, Oracle, IBM), car j'en ai besoin pour le développement, mais d'un seul JRE autonome.

Cela a fonctionné pour moi sur mon ordinateur Windows 2000 + IE 6 à la maison, ainsi que sur mon ordinateur Windows XP + Multiple IE au travail.

1
Jack Leow

Comme cela a été mentionné ici pour JRE6 et JRE5, je mettrai à jour pour JRE1.4:

Vous devrez exécuter l’application jpicpl32.exe dans le répertoire jre/bin de votre installation Java (par exemple, c:\Java\jdk1.4.2 _07\jre\bin\jpicpl32.exe).

Ceci est une version antérieure de l'application mentionnée dans le post de Daniel Cassidy.

1

Utilisez le deployment Toolkit 's deployJava.js (bien que cela garantisse une version minimale plutôt qu'une version spécifique)

0
Stephen Denne

Vous pouvez spécifier la famille de JRE à utiliser. http://www.Oracle.com/technetwork/Java/javase/family-clsid-140615.html

0
user1683903