it-swarm-fr.com

Mise à niveau de la version 2.5 à la version 3.x

C’est une chose sur laquelle je suis curieux depuis quelque temps et qui envisage quelques choses.

Dans quelle mesure la mise à niveau "en un clic" va-t-elle s'améliorer avant l'EoL de Joomla! 2,5?

À l’heure actuelle, le taux de réussite de la mise à niveau à partir de la version 2.5 est très faible. De nombreux problèmes de compatibilité ne sont pas résolus avec la mise à niveau et nécessitent quelques modifications manuelles pour terminer le processus la plupart du temps (les problèmes avec JHTML sont les plus courants). voir).

Maintenant, je parle de "problèmes", mais je veux simplement dire qu’après la mise à jour, les choses ne fonctionnent pas comme prévu, cela ne signifie aucunement que le composant "update" est défectueux.

J'ai regardé autour de moi mais je n'ai trouvé que ce qui suit:

http://docs.joomla.org/Joomla!_CMS_versions

http://developer.joomla.org/cms/roadmap.html

Le premier indique que le support de la version 2.5 en décembre 2014 sera supprimé. La deuxième énonce la feuille de route pour 3.x. Cependant, pour le moment, il est très difficile de mettre à jour la version 2.5, plus le site est volumineux, plus il est difficile. Je ne suis pas sûr de ce qui fait que certains réussissent et d'autres pas, dans la plupart des cas, nous ne pouvons pas l'isoler directement à des extensions tierces (les ruptures de gestionnaire d'extensions et autres à partir de tables manquantes, et le gestionnaire d'extensions est l'endroit où vous corrigez cela).

C’est là que réside le véritable problème de la mise à niveau. Si le site utilise une base de données volumineuse contenant quelque chose comme sobipro, k2 ou le constructeur de contenu, ou seulement de nombreux articles/modules, la mise à niveau peut échouer beaucoup plus facilement. Ceux-ci ne peuvent pas non plus être supprimés, désactivés ou désinstallés (par exemple: plus de 4 000 éléments seraient perdus lors d'une désinstallation, à ce moment-là, vous pourriez aussi bien refaire le site, puis le mettre à niveau).

Alors, existe-t-il un plan pour améliorer la mise à niveau en un clic de la version 2.5 à la version 3.x afin de mieux prendre en charge la fin de fichier? (comme les articles de presse ou les blogs) Une question étrange, mais je pense qu'avec le nombre de sites 2.5 qui ne peuvent pas être mis à niveau, il pourrait être très utile.

15
Jordan Ramstad

mise à niveau "en un clic" fonctionne très bien pour Joomla! 2,5 Core.

Mais votre site peut avoir plusieurs modèles ou extensions à mettre à niveau.

Je prévois également une migration "de juin" de notre site principal. C'est mon plan:

  • Sauvegarder le site principal et créer un nouveau site de test
  • Passez en revue la configuration système requise pour Joomla 3.x et assurez-vous que votre environnement de serveur répond à ces exigences.
  • Installez et personnalisez un nouveau Joomla! 2.5/3 modèle compatible
  • Installez et personnalisez tous les outils Joomla! 2.5/3 extensions compatibles
  • Si une extension n'a pas de version compatible J3, elle doit être remplacée par une nouvelle extension .... ET les données doivent être migrées (dans le pire des cas)
  • NOTE : Les étapes précédentes peuvent être exécutées hors ligne, testées et à la fin, vous pouvez les implémenter dans votre environnement actuel. Joomla! 2.5 site pour réduire le risque de migration d’un jour.
  • Mettez à jour votre site de développement avec le dernier site en ligne
  • Dernière étape: mise à niveau "en un clic" vers Joomla! 3 sur le site de développement
  • Testez et vérifiez tout jusqu'à ce que ça fonctionne Ok
  • Migrez le site en direct (ou restaurez le dernier instantané du site de développement sur un nouvel hébergement ... juste au cas où quelque chose se passe mal et vous devez réactiver le site J2.5)
  • SUCCÈS
11
Anibal

Pour les mises à niveau de la version 2.5 à la version 3.3, j'ai également eu plus de chance de faire une mise à niveau manuelle. Pour les versions, j'irai jusqu'à 2.5.20-> 3.0.3-> 3.1.6-> 3.2.4-> 3.3.0.

C'est le processus complet:

  1. Téléchargez toutes ces versions et décompressez-les sur la machine locale (voici une bonne ressource: http://www.whitefirdesign.com/resources/joomla-release-archive.html )
  2. Sauvegarde avec Akeeba
  3. Créer un site clone dans un sous-dossier en utilisant Akeeba Kickstart (créer/utiliser une nouvelle base de données)
  4. Dans le backend du site web, désinstaller les extensions "problem" (voir bas de l'article)
  5. Sous FTP, téléchargez tous les fichiers d'une nouvelle version de Joomla, à l'exception du dossier/installation /.
  6. Dans le fond du site Web, allez à EXTENSIONS-> EXTENSIONS MANAGER-> DATABASE, puis appuyez sur FIX
  7. Ensuite, allez dans EXTENSIONS-> EXTENSIONS MANAGER-> DECOUVRIR, cliquez sur découvrir et installer pour tout ce qu'il trouve
  8. Allez sur ACL Manager (si vous ne l’avez pas déjà, je le suggère vivement) et corrigez tous les problèmes rencontrés avec ACL. http://aclmanager.net
  9. Répéter le processus avec la prochaine version de Joomla

Une fois que vous êtes arrivé à la dernière version:

  1. Réinstaller les extensions "problème"
  2. Sauvegarde nouvelle version
  3. Site de test pour les problèmes
  4. Déplacer le site d'origine dans un sous-dossier
  5. Déplacez le nouveau site dans la racine pour le mettre en ligne

Ce processus prend beaucoup de temps en raison du temps de téléchargement pour les versions complètes, mais il évite les maux de tête.

Pour les extensions de problèmes, ce ne sont que des problèmes qui ont causé des problèmes lors des mises à niveau. Mon hypothèse est que le paquet d'installation a en fait des versions différentes pour J2.5 vs J3.3, de sorte qu'il devient confus lors de la mise à niveau. Si quelqu'un a trouvé d'autres personnes, faites-le-moi savoir.

  • NoNumbers extensions (Gestionnaire NN, Cache Cleaner, Gestionnaire de module Adv, Modules Anywhere, etc.)

Ces extensions peuvent poser des problèmes si vous n'utilisez pas la version la plus récente:

  • RSForm
  • JW tous les vidéos
  • RokBox
  • RSForm
  • Signets sociaux
  • XMap
4
YellowWebMonkey

Je n'ai pas pu mettre à jour le répertoire de 2.5.7 à 3.2.0. J'ai rencontré diverses erreurs lors de ces mises à niveau, parfois impossible à mettre à niveau.

Le chemin de mise à niveau que je devais prendre comme:

2.5.7 → 3.0.1 → 3.1.5 → 3.2.0

Depuis lors, j'ai pu mettre à jour normalement. J'utilise la version 3.2.2 et envisage de passer à la version 3.3 sous peu.

3
ContextSwitch

Pour répondre à la question principale:

Dans quelle mesure la mise à niveau "en un clic" va-t-elle s'améliorer avant l'EoL de Joomla! 2,5?

Il n’est pas prévu de l’améliorer. Cela fonctionne sans problèmes pour le noyau. Le modèle devra être remplacé en raison d'une sortie modifiée. Les autres extensions doivent être vérifiées manuellement, cela dépend de leur construction. Il est possible d'écrire des extensions fonctionnant à la fois sur les versions 2.5.15+ et 3.x avec la même base de code. Mais il faut vérifier cela soit en essayant, soit en contactant le développeur (ou en lisant sa FAQ).

La seule chose qui peut être améliorée dans la version 2.5 consiste à ajouter un contrôle de compatibilité préalable à la mise à niveau. Il y avait du travail à faire mais ça a stagné. Quelqu'un de la communauté devrait le prendre et le terminer.

2
Bakual

Voici quelques informations utiles que j'ai trouvées sur la mise à niveau.

D'une part, si le site Web était à l'origine en 1.6, puis mis à niveau vers la version 2.5, même dans les dernières versions de la version 2.5, toutes les extensions continueront à fonctionner. Toutefois, la mise à niveau vers la version 3.x nécessite une réinstallation. Cela est dû au fait que les différences dans la zone "update" signifient que s'il était 1.6, le serveur de mise à jour ne lirait pas correctement les mises à jour, donc si c'était un composant 1.6, du moins dans la plupart des cas (je l'ai vu dans DJ Image Slider et BreezingForms) ne seront pas mis à jour une fois sa mise à niveau vers la version 2.5.

Une mise à niveau manuelle de ces extensions est donc nécessaire à un moment donné de sa vie dans la version 2.5. Selon l’extension, je pense qu’il pourrait aussi y avoir des problèmes avec la mise à jour normale de SQL, mais il faut en prendre conscience.

Parfois, les extensions peuvent être renommées ou "renouvelées", ce qui obligera parfois Joomla à le lire en tant que nouveau composant, ce qui entraînera plusieurs entrées du même composant, ancien et nouveau. Si vous en désinstallez un, il utilise toujours les mêmes tables de base de données, donc il les efface si vous les avez déjà installées.

Idée: Il serait donc utile, dans ce cas, d'ajouter un élément supplémentaire au gestionnaire d'extensions afin de vérifier les extensions destinées aux anciennes versions, de les rendre facilement visibles, ce qui pourrait être fait en regardant la "date" de la dernière mise à jour et était-ce avant un éventuel changement radical dans Joomla si la version actuelle est postérieure à cette version

De toute façon, dans le cas d’un site allant de 1,6 à 2,5, puis à 3x à tout moment, peut forcer une réinstallation qui effacerait par conséquent les données.

Une autre idée: Si une "réinstallation" était ajoutée à côté de la mise à jour, utilisez la trace de l'ancienne version et de son serveur de mise à jour, ou une URL/upload personnalisée pour désinstaller le composant sans effacer les données. Ensuite, réinstallez-le en utilisant les mises à jour SQL pour mettre à jour les tables de la base de données, ce qui serait extrêmement pratique.

J'utilise un site qui était à l'origine 1.6 car cela montrerait ces problèmes plus souvent, cela peut arriver aussi avec les sites qui ont commencé dans la version 2.5.

Cela explique de nombreux problèmes pouvant provenir d’extensions qui n’auraient peut-être jamais été mises à niveau pour ajouter de la compatibilité à la version 3.x. Les plugins sont les pires, même dans le panneau d’administration, une erreur risquant de le rendre inutilisable.

Encore une autre idée: Le gestionnaire de mises à jour de Joomla peut désactiver automatiquement tous les plugins tiers autres que certains (comme akeeba, car il suit les mises à jour), puis les mettre à jour. Après qu'il réactive tous les plugins à nouveau, mais "vérifie" les plugins système pour les erreurs. Ce que je veux dire, c’est que cela déclenche automatiquement divers événements avec un essai/attrape pour voir s’il ya une erreur, s’il existe, le désactive et le notifie

Maintenant, tout cela ne suppose aucun problème fondamental, ce qui ne devrait normalement pas se produire dans une mise à jour.

Les idées que j'ai publiées ci-dessus sont destinées à l'équipe de développement, le reste est une bonne information pour les mises à jour. Les idées que j'ai proposées devraient même pouvoir autoriser les mises à jour sans désinstaller/désactiver préalablement les extensions qui pourraient potentiellement l'être. ajouter beaucoup plus de travail au processus. Avec certains ajouts à la mise à jour déjà excellente, même des mises à jour automatiques complètes (un peu comme WordPress) pourraient être possibles dans le futur.

2
Jordan Ramstad

La procédure que j’utilise a évolué au cours d’une quarantaine de mini-migrations Joomla 2.5 à 3.x. Ce n'est pas exactement "un clic" mais permet d'éviter les pièges les plus courants. La plupart des sites Web que je surveille utilisent des modèles RocketTheme et il existe des versions équivalentes à Joomla 3.x des modèles Joomla 2.5, ce qui a réduit les problèmes de migration des modèles pour moi, mais votre kilométrage peut varier.

  1. Vérifiez que l'environnement d'hébergement est compatible avec Joomla 3.x

  2. Lancer la sauvegarde d'abord!

  3. Désinstallez les extensions non compatibles avec Joomla 3.x

  4. Effectuez la mise à jour vers Joomla 2.5.28 si ce n’est pas déjà fait et mettez à jour toutes les extensions tierces vers les dernières versions disponibles de Joomla 2.5.

  5. plugin Désactiver "Système - Se souvenir de moi"

  6. Désactiver le plug-in "Système - Sauvegarde à la mise à jour" si Akeeba Backup est installé

  7. Dans Configuration globale, définissez le rapport d'erreurs sur "Développement" (afin que les erreurs soient visibles après la migration. Si vous manquez cette étape, vous devrez peut-être utiliser FTP, etc. pour télécharger le fichier configuration.php, le modifier pour activer les messages, puis télécharger la version mise à jour via FTP etc qui est une douleur)

  8. Changer les composants -> Mise à jour de Joomla -> Options de "Support à court terme"

  9. Dans Composants -> Joomla Update, cliquez sur "Installer la mise à jour" pour mettre à jour de la version 2.5.x à 3.5.1, 3.5.1 à 3.6.5 puis 3.6.5 à la dernière version. Effacez le cache Joomla et purgez-le dans Extensions -> Extension Manager -> Update et réessayez si la mise à jour n'est pas proposée. Il se peut que vous deviez vous réauthentifier une ou deux fois lors de la mise à jour des jetons de session.

  10. Changer les composants -> Mise à jour de Joomla -> Options -> Mettre à jour le canal sur "Par défaut" s'il n'est pas déjà réinitialisé sur "Par défaut"

  11. Réinstallez les dernières extensions Joomla 3.x par-dessus toutes les extensions installées, en particulier ChronoForms et les actions ChronoForms, le cas échéant.

  12. Effacez le cache Joomla et le cache de votre navigateur Web.

  13. Dans la configuration globale, redéfinissez le rapport d'erreurs sur "Aucun".

  14. Réactiver le plug-in "Système - Sauvegarde à la mise à jour" si Akeeba Backup est installé

  15. Réactiver le plug-in "Système - Mémoriser mes informations"

  16. Désactiver le plug-in "Système - Joomla! Update Notification" pour désactiver les notifications de mise à jour Joomla (facultatif)

  17. Supprimer les modèles Joomla 2.5 (atomic, beez5, beez_20, bluestork)

  18. Activer le contrôle de version dans Contenu -> Articles -> Options -> Modifier la présentation si nécessaire (le contrôle de version est désactivé par défaut)

  19. Désactivez "Autoriser l'enregistrement des utilisateurs" dans Utilisateurs -> Gérer -> Options -> Options utilisateur, le cas échéant (cette option était activée par défaut dans Joomla 2.5).

L'étape 11 est importante pour permettre aux scripts d'installation d'effectuer toute étape spécifique à Joomla 3 qui n'a peut-être pas été exécutée lors de l'installation initiale sur Joomla 2.5.

N'oubliez pas de mettre à jour la version PHP si nécessaire. PHP 5.3 est en fin de vie et PHP 5.6 ou PHP 7.0 ou version ultérieure constitue un meilleur choix pour Joomla 3.x maintenant.

1
Neil Robertson

Je trouve qu'il y a tellement de choses à considérer lors de la mise à niveau que cela ne peut tout simplement pas être considéré comme un processus en un clic.

Les versions de PHP sont la première chose à considérer. Les versions de Joomla aussi ... mettez toujours à niveau la version finale de n'importe quel arbre avant de gravir les échelons. Utilisez Akeeba CMS Updater pour sélectionner les mises à jour que vous souhaitez appliquer et à partir de quelle branche.

Les extensions sont vraiment très poilues.

L'utilisation d'une extension telle que SP) Transfer peut réduire les problèmes en créant un site secondaire pouvant être pré-installé sur la nouvelle version avec tous les composants installés pour cette version, puis en extrayant toutes les données nécessaires de la base de données.

Ce processus n’est cependant pas destiné à l’utilisateur général quotidien.

Le plus souvent, je trouve un problème au niveau de la table des ressources et dois généralement utiliser les diagnostics de ACL Manager pour corriger les éléments orphelins ou manquants de la table.

1
BodgeIT