it-swarm-fr.com

À Ubuntu, je fais des changements à php.ini mais rien ne se passe

Bonjour, Apache avec PHP fonctionne bien, mais aucun des changements que je nets chez PHP.ini n'a d'effet, j'ai même supprimé tout le contenu du fichier, puis redémarrez Apache et exécutez phpinfo () et surprenant tout va bien fonctionner.

Le fichier que je dois éditer est celui qui apparaît dans le fichier phpinfo () comme "fichier de configuration chargé". (/etc/php5/apache2/php.ini)

P.s. Je cours Ubuntu 9.04 et PHP 5.2

Plus de détails:

Je redémarre avec sudo /etc/init.d/tache2 redémarrage, j'ai aussi essayé sudo /etc/init.d/apache2 stop, puis commencer, à redémarrer je reçois:

  • Redémarrage du serveur Web Apache2 Apache2: Impossible de déterminer de manière fiable le nom de domaine entièrement qualifié du serveur, à l'aide de 127.0.1.1 pour serveurName ... en attente Apache2: Impossible de déterminer de manière fiable le nom de domaine entièrement qualifié du serveur, à l'aide de 127.0.1.1 pour le nom de serveur [OK].

"Quel php" n'a produit aucun résultat.

Mon installation de PHP a été effectuée à l'aide de Synaptic Package Manager, en choisissant "Marquer des packages par tâche", puis le serveur de lampe.

Je n'ai aucune idée de quoi faire ...

12
MrAn3

On dirait que vous changez le mauvais php.ini - Vérifiez l'emplacement de php.ini qui est donné dans la sortie phpinfo ()! Cela vous montrera le php.ini qui est en fait utilisé.

Vérifiez également si le redémarrage Apache a vraiment réussi. ;)

9
Lennart

Assurez-vous d'éditer le bon fichier. Il y a plusieurs fichiers pour différentes circonstances ((( au moins sur Jaunty ) nichée dans /etc/php5/

Pour apache + mod_php, vous voulez /etc/php5/Apache2/php.ini

8
Oli

Vérifiez que vous n'utilisez pas 2 fichiers php.ini - un pour le module de serveur Web et un autre pour la version CLI.

1
Flavius Stef

Il continue de fonctionner car PHP fonctionnera sans fichier php.ini, mais il fonctionne avec toutes les options de la compilation.

Quels changements faites-vous qui ne figurez-vous pas dans la sortie phpinfo ()?

1
dragonmantank

J'ai eu le même problème et pour ceux qui répondent devant moi, non je ne monte pas le mauvais fichier.

Je cours Ubuntu 10.04 en cours d'exécution Nginx et mon PHP Installation utilise php-fpm. Php-fpm semble être ce qui cause le problème.

Pour résoudre le problème, j'exécute PHP-FPM à partir de la ligne de commande. (Tapez simplement PHP-FPM et appuyez sur ENTER.)

Dans mon cas, cela me donne quelques avertissements sur les modules non trouvés, puis sortit.

Après cela, PHPInfo affiche les valeurs correctes, sans redémarrer le serveur Web.

J'espère que ça aide.

1
Adrian Schmidt

J'utilise Ubuntu 10.04 (lucide). Pour que les modifications apportées à PHP.ini fonctionnent, vous devez redémarrer le système. Redémarrer Apache n'est pas suffisant.

0
Hanafi

Je ne sais pas pourquoi, mais service Apache2 reload semblait réussir mais n'a pas abouti à des modifications reflétées dans la production de phpinfo. Fonctionnement Sudo service Apache2 reload travaux. Ceci est à Ubuntu 14.04.

0
Daniel Centore

Dans Config.PHP Change ServerName="127.0.1.1" à

ServerName="Localhost"
0
LinuxKing

DO find / -type f -name "php.ini" Cela sortira tous les fichiers nommés php.ini.

Découvrez lequel vous utilisez-vous, généralement Apache2/php.ini.$ Modifier et profiter.

phpinfo(); pourrait vous aider à savoir lequel est utilisé. lsof pourrait également vous aider.

0
thms0

Ouvrez le terminal et tapez

which php

Ensuite, vous saurez quelle version vous avez et vous pouvez aller de là. Je vérifierais également que vous avez correctement redémarré votre serveur Apache.

0
PSU_Kardi