it-swarm-fr.com

Pourquoi WordPress reçoit-il des publications de MySQL à partir d'un nom d'hôte virtuel mais pas du nom d'hôte direct?

Je développe un site WordPress sur mon Mac, sous OS X 10.6.4. J'utilise le serveur Apache intégré d'OS X pour exécuter le site localement pendant le développement. J'ai configuré WordPress et l'ai connecté à MySQL sous OS X sans aucun problème. Le site semble fonctionner correctement, et je peux poster, éditer, etc.

L'installation de WordPress se trouve dans un dossier appelé ~/Sites/mysite.dev.

J'ai également personnalisé mon fichier .hosts et le fichier httpd-vhosts.conf d'Apache pour rediriger les demandes de mysite.dev vers ce dossier. Ainsi, lorsque je saisis http://mysite.dev dans une fenêtre de navigateur, le site se charge. Pas de problèmes ici.

Je peux donc accéder au site, dans un navigateur, à partir de deux adresses différentes, http://mysite.dev et http://localhost/~Gabe/mysite.dev/.

Voici ce qui est étrange: quand je vais à http://mysite.dev, le site WordPress se charge normalement. Lorsque je vais à http://localhost/~Gabe/mysite.dev/, WordPress ne trouve aucun article dans la base de données: le message "Désolé, aucun article ne correspond à vos critères" (qui est intégré au thème dans lequel une recherche d'articles ne renvoie rien). NB: Apache traite normalement le code PHP dans les deux cas - mais dans un cas, WordPress peut recevoir des publications de MySQL et dans l'autre cas, il ne le peut pas.

Ma première pensée a été que c'était un problème avec la configuration de WordPress. J'ai donc changé l'URL de WordPress en http://localhost/~Gabe/mysite.dev/, mais cela ne faisait aucune différence.

Je ne comprends pas pourquoi l'utilisation des deux adresses produit des résultats différents. Toute aide appréciée.

(Voici pourquoi je m'en soucie, au cas où vous vous le demanderiez: je veux prévisualiser le site dans la fenêtre d'aperçu Web de BBEdit, et BBEdit ne chargera le site que via l'adresse http://localhost/~Gabe/mysite.dev/.)

2
Gabe

J'ai réussi à résoudre ce problème - il s'avère que WordPress se comporte mieux lorsque je règle l'adresse (Word) et l'adresse du site sur http: //localhost/~Gabe/mysite.dev/ .

1
Gabe