it-swarm-fr.com

Je reçois "Le PHP La bibliothèque date/heure n’est pas prise en charge par votre hébergeur Web. "Sur mon hôte CentOS, quelle bibliothèque dois-je installer pour ajouter une prise en charge?

J'ai fait quelques recherches rapides, mais mes PHP compétences sont plutôt naissantes. Je suis sûr qu’il n’ya qu’un paquet à installer.

Modifier pour ajouter des informations supplémentaires sur la configuration:

En utilisant:

yum info php

Je reçois la version de PHP comme 5.1.6:

Name       : php
Arch       : i386
Version    : 5.1.6

Plus d'informations, il s'agit d'un VM sur lequel CentOS est exécuté sur GoDaddy:

CentOS release 5.4 (Final)
1
Larry Smithmier

Mise à niveau vers PHP 5.2 ou version ultérieure

Le message d'erreur que vous voyez est de WordPress. En réalité, il est très trompeur de dire que vous avez besoin d'une version PHP => 5.2 pour que cette fonctionnalité fonctionne.

Consultez la documentation de votre système d’exploitation ou contactez le support technique pour savoir comment mettre à jour votre version de PHP. Pour CentOS, par exemple: CentOS HowTos: PHP 5.1 à 5.2

Garder les fuseaux horaires améliorés

Pour tirer le meilleur parti du support du fuseau horaire PHP , un package PECL contient toutes les dernières mises à jour: timezonedb .

Donc, à côté de la mise à niveau de PHP vers une version récente, vous pouvez installer ce paquet PECL et le maintenir à jour pour obtenir les dernières mises à jour du fuseau horaire (la dernière en date du 16 août):

$ yum install php-pear php-devel
$ pecl install timezonedb
3
hakre

wp-admin/options-general.php renvoie le message d'erreur suivant:

Malheureusement, vous devez le mettre à jour manuellement pour l'heure d'été. La bibliothèque Date/Heure PHP n'est pas prise en charge par votre hôte Web.

Ce bloc de code sera généré si les fonctions suivantes fournies par PHP sont manquantes:

Beaucoup de ces fonctions sont fournies par la famille de classes DateTime . Celles-ci font partie de PHP core depuis la version 5.1/5.2, en fonction de la fonction en question. Bien que je déteste demander des éclaircissements dans une réponse: quelle version de PHP votre hôte est-il en cours d'exécution?

1
Annika Backstrom

Smithmier **:

UPDATE: Je vois dans votre mise à jour que cela ne s'applique pas à vous mais que cela s'appliquerait à beaucoup d'autres personnes ayant le même problème et que nous cherchons des réponses générales à des questions. qui s’appliquent à plus d’une personne que je vais laisser.


Je suppose que @hakre a raison et si et si votre hébergeur propose CPanel pour vous permettre d'administrer les éléments techniques de votre compte d'hébergement Web. alors voici où vous pouvez changer votre version de PHP:

Screenshot for PHP Configuration on CPanel
(source: mikeschinkel.com )

Ce qui vous amène ensuite à cet écran où vous pouvez changer votre version de PHP:

Changing your version of PHP on CPanel
(source: mikeschinkel.com )

1
MikeSchinkel